Q-Tron Problem

Effects pedals or devices to alter the sound of your bass
Post Reply
Kelburn
Bronze Member
Posts: 26
Joined: Tue Apr 06, 2010 1:27 pm

Q-Tron Problem

Post by Kelburn » Tue Apr 06, 2010 1:34 pm

Birthday present off ebay.
Electro-Harmonix Q-Tron pedal for my Bass.

I only got it today, and I plugged it in with the supplied 120v 60Hz power pack with a simple socket adapter. It played fine for a couple of mins till I turned on the boost and it cut out. I heard a spark from the power pack (I think not 100% sure) and it did smell a bit burnt...
I followed the exact instructions and plugged in only the power pack they provided.
What do I do? I've emailed EHX and the person I bought it off, and am just waiting for s response (probably tonight though coz of time differences).

Thanks in advance,
Kelburn

foal30
Gold Member
Posts: 1749
Joined: Fri Dec 01, 2006 8:36 pm
MySpace Page: myspace is owned by Lucifer himself
Bands / Groups: Pony Jones
Location: Chch

Re: Q-Tron Problem

Post by foal30 » Tue Apr 06, 2010 3:22 pm

Kelburn = Aotearoa?

if so 120v might be a real burning issue.Rog (Jazz Bass) will let us know when he sees this.
Slave to the Rhythm Changes

User avatar
joppo
Moderator
Posts: 724
Joined: Tue Jun 12, 2007 4:11 pm
Location: Dunedin

Re: Q-Tron Problem

Post by joppo » Tue Apr 06, 2010 4:18 pm

Yeah - 240v into a 120v device isn't going to be good. If you are lucky, you'll have fried the power supply. If you are unlucky, you could have fried the pedal. Does the power supply have "110-240V" written on it? If it does then it should have automatically detected the input voltage and you have a warranty claim. If it just has "120V", then it then you will have voided the warranty.

The pedal takes 24V DC and the jack is inner positive according to the EH website. The way to find out if the pedal is OK is to take your 120V power supply to your local Dick Smith or Jaycar and ask them for a 240V power supply with the same jack and ouput voltage. You'll need that anyway if the pedal is OK. Hopefully the power supply gave up rather than the pedal.

Kelburn
Bronze Member
Posts: 26
Joined: Tue Apr 06, 2010 1:27 pm

Re: Q-Tron Problem

Post by Kelburn » Wed Apr 07, 2010 6:21 pm

Hey, thanks for your reply. I checked it out at a Music Planet store. The unit seems to be working fine. They are ordering in a power pack for me to buy (from overseas). If I had known though I would have bought the pedal from them!

User avatar
joppo
Moderator
Posts: 724
Joined: Tue Jun 12, 2007 4:11 pm
Location: Dunedin

Re: Q-Tron Problem

Post by joppo » Wed Apr 07, 2010 6:39 pm

Great to hear the pedal is fine! Hope the new power supply doesn't take long to arrive :D

Kelburn
Bronze Member
Posts: 26
Joined: Tue Apr 06, 2010 1:27 pm

Re: Q-Tron Problem

Post by Kelburn » Wed Apr 07, 2010 8:09 pm

Thanks. They said a month so... Probably one of my most relieved moments ever!

irvinz
Gold Member
Posts: 503
Joined: Sun Dec 02, 2007 12:01 pm

Re: Q-Tron Problem

Post by irvinz » Wed Apr 07, 2010 8:10 pm

joppo wrote:Great to hear the pedal is fine! Hope the new power supply doesn't take long to arrive :D
fat hopes.... plus i don't think it would come from overseas?
ex- Music Planet Queen Street Resident Bass expert wannabe

now residing at vinzmusic.com

Kelburn
Bronze Member
Posts: 26
Joined: Tue Apr 06, 2010 1:27 pm

Re: Q-Tron Problem

Post by Kelburn » Wed Apr 07, 2010 10:33 pm

The guy said they had to order them in from overseas... I dunno how the whole thing works tbh though.

irvinz
Gold Member
Posts: 503
Joined: Sun Dec 02, 2007 12:01 pm

Re: Q-Tron Problem

Post by irvinz » Thu Apr 08, 2010 4:19 am

thats all good. i can almost guarantee that they don;t bring it in from overseas.. the power supplies.....
they are sourced locally.

which q tron is it? if its any of the big box versions, then grab a 24V from jaycar or dse. something that does 100mA should be sufficient from memory.

which music planet did you walk into?
ex- Music Planet Queen Street Resident Bass expert wannabe

now residing at vinzmusic.com

irvinz
Gold Member
Posts: 503
Joined: Sun Dec 02, 2007 12:01 pm

Re: Q-Tron Problem

Post by irvinz » Thu Apr 08, 2010 4:19 am

with this in mind, i should update my sig :)
ex- Music Planet Queen Street Resident Bass expert wannabe

now residing at vinzmusic.com

Post Reply